Notices

Trademark

Bentley and the “B” Bentley logo are either registered or unregistered trademarks or service marks of Bentley Systems, Incorporated. All other marks are the property of their respective owners.

Copyright

Copyright © 2012 Bentley Systems, Incorporated. All Rights Reserved.
This page intentionally left blank
# Table of Contents

## Chapter 1: Learning How to Use MicroStation ................................................................. 7
- File Open Dialog ........................................................................................................... 7
- Application Window ..................................................................................................... 8
- Menus ...................................................................................................................... 8
- Toolboxes .................................................................................................................. 8
- Tasks ....................................................................................................................... 9
- View Windows .......................................................................................................... 10
- Status Bar .............................................................................................................. 10
- New Files .................................................................................................................. 10
- Quick Start Guide Workflow ...................................................................................... 10

## Chapter 2: Design Models ............................................................................................. 13
- To View a Completed 3D Design Model ...................................................................... 13
- To Use the Models Dialog to Open a Model ............................................................... 13
- To Create a Foundation for a House Using the Slab Solid Tool ................................. 14
  - To Unite the Two Parts of the Foundation Using the Unite Solids Tool ................ 17
- To Create the Walls for the House ........................................................................... 18
- To Add a Door or a Window to the House ................................................................. 20
- Alternative Method to Add Windows to the House .................................................... 22
- To Create a Roof for the House .............................................................................. 24
- To Attach Materials to a Design .............................................................................. 27
- To Get Information About an Element ..................................................................... 29
- To Attach a Reference to the House Design Model .................................................. 30
- To Turn Off a Level .................................................................................................. 33

## Chapter 3: Creating Drawing Models and Sheet Models ............................................... 35
- To Create a Drawing Model for Complete Design Models ......................................... 35
- To Create a Drawing Model and a Sheet Model Using Drawing Composition Tools .... 36
  - To Attach a Border to a Sheet Model ................................................................ 37

## Chapter 4: Rendering a Completed Design ................................................................. 41
- To Set the Camera for a Rendering ........................................................................... 41
- To Create a Rendering of the House ........................................................................ 42

## Chapter 5: Creating Deliverables .................................................................................. 45
- To Print a 2D Sheet Model ....................................................................................... 45
- To Create a 3D PDF ................................................................................................ 46
- To Create an i-model .............................................................................................. 46

## Chapter 6: Additional Resources .................................................................................. 49
- Key Concepts and Tools ......................................................................................... 49
  - AccuSnap ........................................................................................................... 49
  - Design History ................................................................................................... 50
  - Design Plane and Design Cube .......................................................................... 50
  - DGN Libraries .................................................................................................... 50
Element Attributes ........................................................................................................................................51
Levels ...........................................................................................................................................................51
Project Explorer and Link Sets .....................................................................................................................52
Seed Files ...................................................................................................................................................53
Workspaces ..................................................................................................................................................54
The Bentley Institute ........................................................................................................................................57
Be Communities ..........................................................................................................................................57
Learning How to Use MicroStation

The Quick Start Guide introduces you to commonly used features of MicroStation. If you want to learn more about how to use MicroStation, there are additional resources available. The Help document within MicroStation, available by selecting Help > Contents, contains information about the product and procedures to use the different features.

The Bentley Institute offers a variety of training courses for MicroStation.

Bentley System, Incorporated has a YouTube channel where you can find videos about MicroStation.

File Open Dialog

The File Open dialog is the first dialog you see when you open MicroStation.

The New icon, Bentley icon, Folder icon, and Workspace components on the right side of the dialog are not Windows defaults. If you know the Workspace components of the file you want to open, you can navigate to its location using User, Project, and Interface. If you do not know details about the file, you can navigate through the file hierarchy. A DGN file will most likely be found in a DGN folder. Select the QuickStart.dgn
file from "...\Workspace\Projects\Examples\General\Dgn". The file displays in the Preview pane; you can see what the file contains before opening it. Click Open.

Application Window

The MicroStation application window contains menus, toolboxes, dialogs, tasks, view windows, and a status bar. Not all are available by default. Some tools, toolboxes, and dialogs dock to the top, bottom, and sides of the application window.

Menus

The main menu bar displays at the top of the application window. The menus are File, Edit, Element, Settings, Tools, Utilities, Workspace, Window, and Help. Some dialogs have menu bars. The menu items on dialogs vary depending on the contents of the dialog and can include the menu items from the main menu bar as well as others.
Contextual Menus

MicroStation has pop-up, contextual (right-click) menus. These menus contain items that operate on the control or object at the pointer location.

Toolboxes

The Attributes toolbox and Primary Tools toolbox display by default.

The Attributes toolbox contains controls for setting how the elements in your model display.

The Primary Tools toolbox contains commonly used dialogs and tools.

Tasks
The Tasks dialog on the left side of the screen displays the Main task along with additional tasks. The additional tabs are named after common MicroStation tasks. They contain groups of tools commonly used to complete each task. Additional tabs are available for 3D.

**View Windows**

View Windows are where you create your designs. You can have up to eight view windows open at a time. The view rotations available for 3D models are Top, Front, Right, Isometric, Bottom, Back, Left, and Right-Isometric. The Window menu contains the controls for View Windows.

**Status Bar**

![Image of status bar]

The status bar at the bottom of MicroStation provides prompts, context-sensitive assistance, and some interactive functionality. It contains the Snap Modes and Locks menus.

**New Files**

New DGN files are created using seed files. Seed files are DGN file templates that contains preset values such as initial element parameters, dimensionality (2D or 3D), and working units settings. Several seed files are delivered with the product. The default seed file is 2D. If you do not set the seed file, the default seed file will be used. When working with MicroStation, units are most likely set in the seed file.

**Quick Start Guide Workflow**

- **Design Model**
  - 3D
  - Create a Design
  - Attach Materials
  - Set up Camera
  - Rendering

- **Drawing and Sheet Model**
  - Drawing Models:
    - 2D
    - Contains
    - Annotations
    - Dimensions
    - Callouts
  - Sheet Models:
    - 2D
    - Contains printable information

- **Design Deliverables**
  - 2D Sheet Model
  - Print
  - 3D PDF
  - i-model
The Quick Start Guide is set up to follow its own workflow. This is not the only type of workflow available in MicroStation. This workflow allows you to use the three types of MicroStation models along with commonly used tools to create deliverables. It is a concise way of learning the most about the types of models and what you can do with each model type.

The QuickStart.dgn takes you through the process of creating a simple house. It contains an example of what a completed house could look like after completing all the exercises. Each major exercise corresponds with a model that shows the progression towards the completed house model. You can use these models as guidelines for your own work. The My House model is set up for you to start your house model.
This page intentionally left blank
A design model consists of design geometry that is added and manipulated using the tools available in MicroStation.

**2D or 3D Design Models**

A design model can be either 2D or 3D. Some tools are only available for 3D models.

**To View a Completed 3D Design Model**

To correctly create design elements, you must be able to see where they are located within the design model.

1. Open QuickStart.dgn.
   The model that opens, Completed Model, is a completed 3D design model. One view window is open. You can have up to eight view windows open at a time. The open view window's view rotation is Isometric.

2. Optional: You can use the Rotate View tool from the View toolbox to look at the completed 3D design model.

3. Optional: When you are finished using the Rotate View tool, use the View Rotation drop-down list to return the view window to the Isometric view.

4. Optional: If the model does not fit in the view window, use the Fit View tool from the View Control toolbox.
   The model fits in the view.

**To Use the Models Dialog to Open a Model**

1. Click the Models icon or the arrow next to the Models icon on the Primary Tools toolbox.
   The Models dialog opens.
Design Models
To Create a Foundation for a House Using the Slab Solid Tool

2. Double-click the model named My House.
   The selected model opens.

The My House model is where you will create your house design model. It consists of one open view window in the Isometric view rotation.

To Create a Foundation for a House Using the Slab Solid Tool

The AccuDraw window is docked at the bottom of the application by default. The AccuDraw compass is visible when AccuDraw is active. AccuDraw uses rectangular or polar coordinates. The AccuDraw window and compass assist you in creating your design geometry. You enter numerical inputs into the AccuDraw window and then determine the direction with the AccuDraw compass. AccuDraw's common shortcuts can be found in Help > AccuSnap and AccuDraw > Working with AccuDraw > AccuDraw’s Shortcut Key-ins, or by selecting <Shift + ?> when AccuDraw is active, which will open a dialog with all the shortcuts. These shortcuts increase the ease of use of AccuDraw.

AccuDraw window docked along the bottom edge of the application.

AccuDraw compasses. Left: Rectangular coordinate system. Right: Polar coordinate system.

1. Select the Slab Solid tool from the Primitive Solids toolbox, labeled with an E, on the Solids Modeling task.
The window that opens is the tool settings window for the Slab Solid tool. Many tools have settings that can be set to your specifications.

2. In the Slab Solid tool settings window:
   a. Set Axis to Points (AccuDraw).
   b. Check Orthogonal
   c. Check Length and type 20
   d. Check Width and type 25
   e. Check Height and type 1

3. In the Isometric view, enter the start point for the slab solid at the ACS origin (0,0,0).
   The ACS origin is located at the vertex of the red X arrow and green Y arrow.


5. Move your cursor in the X or Y direction. Click <Enter>.
   
   <Enter> is the AccuDraw shortcut for Smart Lock. The side of the linear solid locks to the X or Y axis.

6. Enter the length of the slab solid.

7. Move your cursor in the direction (X or Y) that you did not use previously.

8. Enter the width of the slab solid.

9. Move your cursor in the Z direction.

10. Enter the height of the slab solid.
Part of the foundation of the house is created.

11. Repeat steps 1 to 10 with the same settings in the tool settings window except:
   a. Check Length and type 20
   b. Check Width and type 15

Create the second part of the foundation adjacent to the first part.
The second part of the foundation is created.

**To Unite the Two Parts of the Foundation Using the Unite Solids Tool**

1. Select the Unite Solids tool from the Modify Solids toolbox, labeled with a T, on the Solids Modeling task.
   The Unite Solids tool settings window opens.
2. In the tool settings window, set Keep Originals to None.
3. Select one of the parts of the foundation.
4. Select the other part of the foundation.
5. Accept to construct the union.
A unified foundation is created. If you want to check the location and shape of your foundation, open the model Step 1 Foundation to see the foundation for the Completed Model.

**To Create the Walls for the House**

1. Select the Linear Solid tool from the Create Solids toolbox, labeled with an R, on the Solids Modeling task.

   The window that opens is the tool settings window for the Linear Solid tool.

2. Set the tool settings:
   a. Place by: Outside
   b. Width: 1
   c. Height: 4

3. In the Isometric view, enter the start point for a rectangular linear solid.
4. Rotate AccuDraw to the Top rotation.
5. Move your cursor in the X or Y direction.
6. Lock AccuDraw to the selected direction.
7. Move your cursor along the X or Y direction until a yellow heavy line weight "X" appears.
   The yellow heavy line weight "X" is the AccuSnap, which is set to snap to the nearest keypoint.
8. Enter a data point to create the first side of the linear solid.
9. Use Smart Lock, AccuDraw, AccuSnap, and the prompts from the status bar to create the remaining the linear solid.

The exterior wall of the house is created.

10. Repeat steps 1 to 8 to create interior walls that create two interior rooms in the house. You can choose the dimensions of the rooms.
The walls of the house are created. If you want to check the location and shape of the walls in the Completed Model, open the model Step 2 Walls.

**To Add a Door or a Window to the House**

For this exercise, you need to have the Isometric view and View 3, the Front view open. You can open View 3 from the View Groups window.

Use the Fit View tool when necessary.

1. Select the Draw on Solid tool from the Modify Solids toolbox, labeled with a T, on the Solid Modeling task.
   
   The Draw on Solid tool settings window opens.
2. Select the Draw Block icon.
3. In the Front view window, place a rectangle with the dimensions 2x3 that could be used as a door. The rectangle appears on the front face. If you want to check that you correctly used the Draw on Solid tool, open the model Step 3 Draw on Solid to see the window and door placement for the Completed Model.

4. Select the Modify Solid Entity tool from the Modify Solids toolbox, labeled with a T, on the Solid Modeling task.

The Modify Solid Entity tool settings window opens.

5. Select the Face icon.
6. Select Full Dynamics.
7. In the Front view, select the rectangle.
   A dotted yellow line appears.
8. Select within the rectangle to make it the active face.
9. In any of the views except the Front view, define the distance so that the rectangle is the full width of the wall.
A door is created for the house.

10. Optional: You can create additional doors for the house. You can also create windows for the house using this method or by using the Alternative Method below.

Create windows with the dimensions of 2x1, 2x2, or 4x2. Create doors with the dimensions 2x3.

If you want to check that you correctly used the Modify Solid Entity tool, open the model Step 4 Modify Solid Entity to see the window and door placement for the Completed Model.

**Alternative Method to Add Windows to the House**

If you want to add windows to your house, you can use the Slab Solid tool and the Subtract Solid tool. Using this method allows you to create windows of a uniform size. Create windows with the dimensions of 2x1, 2x2, or 4x2.

1. Select the Slab Solid tool from the Solids Modeling task.

The Slab Solid tool settings window opens.
2. In the Top view, enter the start point of the slab solid on one of the wall boundaries. It can be the interior boundary or the exterior boundary.
3. Move your cursor into the Isometric view.
4. Rotate the AccuDraw compass to the Front orientation (AccuDraw shortcut <F>).
5. Define the length of the slab solid.
6. Define the width of the slab solid.
7. Define the height of the slab solid.
   The slab solid is created.
8. Select the Move tool from the Manipulate toolbox (the third toolbox) drop-down list on the Main task, by pressing and holding the data button until the drop-down list appears. The Move Element tool settings window opens.
9. Select the slab solid.
10. From the Isometric view, move the slab solid to the desired location.
    a. Open another view window using the View Groups toolbox to ensure that you are not moving the slab solid away from the wall.
    b. Make sure the slab solid goes completely through the wall.
11. Optional: From the Main task, select the Copy tool from the Manipulate toolbox. The Copy Element tool settings window opens.
12. Optional: Select the slab solid.
13. Optional: In any view except Isometric, copy the slab solid to the desired location.
    a. Use AccuDraw shortcuts to rotate the AccuDraw compass to the appropriate rotation for the active view.
14. Optional: Enter a data point to accept the location of the copy of the original slab solid. A copy of the original slab solid is created.
16. Select the wall of the house (the solid to subtract from).
17. Select a slab solid (the solid to subtract).
18. Optional: <Ctrl + Click> to select additional slab solids.
19. Enter a data point to accept the subtraction(s).
A window(s) is created.

Your house now has window features.

To Create a Roof for the House

1. Select the Pyramid Solid tool from the Primitive Solid toolbox, labeled with an E, on the Solids Modeling task.

   The Pyramid Solid tool settings window opens.
Design Models
To Create a Roof for the House

2. Set the tool settings:
   a. Method: Rectangle
   b. Check Orthogonal
   c. Check Base Length and type 27
   d. Check Width and type 22
   e. Check Height and type 2.5
   f. Check Top Length and type 27
   g. Check Top Width and type 0

3. Select a corner of one of the rectangles that make up your house.
4. Lock AccuDraw to the Y axis.
5. Rotate the AccuDraw compass to the Top orientation (AccuDraw shortcut <T>).
6. Enter the base length.
7. Enter the base width.
   The base of the pyramid is created.
8. Move your cursor in the positive Z direction.
9. Enter the height.
10. Enter the top width.
    A pyramid solid is created.
11. Select the Move tool from the Manipulate toolbox (the third toolbox) drop-down list on the Main task.
    The Move tool settings window opens.
12. Move your cursor in the X direction and type -1 into AccuDraw.
13. Move the roof in the X direction.
14. Move your cursor in the Y direction and type 1 into AccuDraw.
15. Move the roof in the Y direction.
The roof is placed.

16. Repeat steps 1 to 14 with the same settings in the tool settings window except:
   a. Check Base Length and type 26
   b. Check Top Length and type 26
The house has a complete roof. If you want to check the placement of the roof, open the model Step 6 Roof to see the roof for the Completed Model.

### To Attach Materials to a Design

For a design to appear realistic, you have to include materials in your design model.

1. Select the Define Materials tool from the Materials toolbox, labeled with an A, on the Visualization task.
   
   The Material Editor (Basic Mode) dialog opens.
2. Click the Open Palette icon.  
   The Open Palette dialog opens.
3. Select an appropriate palette.  
4. Click OK.  
   The selected palette opens in the palette tree.
5. Select a material from the palette.  
   A preview of the selected material displays in the preview window.
   The Attach Material dialog opens with the Attach icon selected.
7. Identify the element to attach the material to in your design model.
8. Optional: Attach the material to the element by selecting a face.
9. Optional: <Ctrl + click> to select additional faces.
10. Optional: Use <Shift + mouse wheel button> to rotate the view to select faces that are behind other faces.
11. Enter a data point to accept the attachment of the material.  
   The material is attached to the element.
12. Use the Material Editor dialog and the Attach Material dialog to attach materials to the house elements without attached materials.

If you want to see the materials used for the Completed Model, open the model Step 7 Materials.
To Get Information About an Element

1. Select Element Information from the Primary Tools toolbox.
2. Select the Element Selection tool from the Main task.
3. Select an element that is part of your house.

The Element Information dialog opens. Information about the selected element displays.
4. In the Material tab, you can see the name of the material assigned to the different elements of the house.

**To Attach a Reference to the House Design Model**

If you ever want to add another design model's elements into your active design model, you can do so by attaching a reference. A reference cannot be modified in the active design. If you were working on a house for
Design Models
To Attach a Reference to the House Design Model

...a larger project and someone was working on the garage, you could reference in the garage so you would know what it looked like and where it would appear in relation to your house.

1. Click the References icon \[\text{\includegraphics[width=2cm]{reference_icon.png}}\] from the Primary Tools toolbox.

   The References dialog opens.

   ![References Dialog](image.png)

   2. Select **Tools > Attach**.

   3. Navigate to the "\text{\ldots\WorkSpace\Projects\Examples\General\Dgn}".

   4. Select the QuickStart.dgn file.

   5. Click Open.

   The Reference Attachment Settings dialog opens.
7. Click OK.
   The reference model opens in your active design model.
8. Select the Fit View tool if you do not see the reference.
9. Select the reference in the References dialog.
10. Select the Element Selection tool.
11. Move the Reference by selecting the pink checked box around the reference.
If there are any changes made to the garage design model, changes will reflect in your house design model. If you need to edit the reference, select Tools > Exchange from the References dialog.

If you want to check the location of the reference, open the model Step 8 Reference to see the reference of the garage in the Completed Model.

**To Turn Off a Level**

Your house and the garage reference exist on two levels in the design model. Levels are analogous to transparent overlays. In different combinations they make it easier to see parts of a model. If you turn off a level, the design elements on that level do not display.

**Note:** It is suggested that you use multiple levels for creating model elements so you do not have an entire project on the default level.

1. Click the Level Display icon from the Primary Tools toolbox.

   The Level Display dialog opens.

2. Select QuickStart.DGN, Garage.

   Selecting a level from the Levels list box turns the level on or off. By default, levels are on when they are highlighted in blue and off when they are not highlighted.

3. Turn off the Default level.

   The garage does not display. The house continues to display because it is not on the reference's default level.

4. Turn on the Default level.

   The garage displays.
Creating Drawing Models and Sheet Models

A drawing model stores information from different design models in one central location. It is always 2D. A drawing model is where you would store annotations, dimensions, and callouts. Its default background is gray. A sheet model is like a sheet of drafting paper. It contains printable information for your designs.

Creating a Drawing Model

You can create a drawing model that references in complete design models or parts of a design model.

Sheet Models and References

Sheet models can have references attached containing design and drawing model information. A design can be referenced by multiple sheet models that use different drawing models; therefore, when the design model changes the different sheet models will reflect the change because of the attached references. If you did not use references, you would have to have a different design model for each sheet model. Creating multiple copies of the same design model and updating each with every change is unnecessary when you use references.

To Create a Drawing Model for Complete Design Models

1. Click the Models icon from the Primary Tools toolbox. The Models dialog opens.

2. Click the New icon.
   The Create Model dialog opens.

3. Set Type to Drawing.
4. In Name, type Plan for Completed Design Model.
5. Optional: In Description, enter a description for your drawing model.
6. Click OK.
   Your drawing model is created.
7. Attach the desired design models as references with a Top orientation.

To Create a Drawing Model and a Sheet Model Using Drawing Composition Tools

If you want a drawing model where the drawing resembles a floor plan, you can use the Place Plan Callout tool.

1. Select the Place Plan Callout tool from the Annotate Toolbox, labeled with an R, on the Drawing Composition task.
   The Place Plan Callout tool settings window opens.

2. Set Drawing Seed to Plan_English_C.
3. Turn on the Create Drawing check box.
4. In the Front view, define the start point for the callout.
   The start point should be located outside of the house.
5. Define the end point for the callout.
   The end point should be located outside of the house.

The line between the start and end points becomes the boundary for the floor plan.

6. Define the depth of the plan.
   The Create Drawing dialog opens.
7. Turn on the Create Drawing Model check box.
8. Change the annotation scale to 1/4"=1'0".
9. Turn on the Creat Sheet Model check box.
10. Change the annotation scale to 1/4"=1'0".
11. Click OK.

One model that opens is a drawing model. The other model is a sheet model.

If you go back to your house design model and select the callout icon, you will see that a pink border shows the boundaries of the plan callout. The callout mini toolbar contains tools for using the callout. You can open it by clicking the callout icon. It is gray until you place your cursor over it.

**To Attach a Border to a Sheet Model**

1. Click the References icon from the Primary Tools toolbox.

   The References dialog opens.
2. Select **Tools > Attach**.
3. Navigate to the "...\WorkSpace\System\Borders\ANSI".
4. Select the C-border.dgn file.
5. Click Open.
6. Select the following settings:
   a. Model: 1:1 Full Scale
   b. Orientation: Coincident
   c. Scale (Master:Ref): 48:1
   d. Nested Attachments: Live Nesting with a Nesting Depth of 99

7. Click OK.
The border is attached to the sheet model.
Creating Drawing Models and Sheet Models
To Create a Drawing Model and a Sheet Model Using Drawing Composition Tools
Rendering with the Luxology Render Dialog

A completed design that needs to appear as it actually would in an environment can be rendered to achieve the correct real-world look and feel. You can create a rendering of your design using different materials, lighting, and camera settings. Rendering is the process of depicting a 3D model through the display of shaded surfaces. You can render your completed designs to give them a real world appearance or an abstract appearance. The Luxology Render dialog is where you adjust the settings for your render.

To Set the Camera for a Rendering

The placement of the camera is important to ensuring that a render will generate with the desired appearance.

1. Select the Setup Camera tool from either the Cameras toolbox, labeled with an E, on the Visualization task or from Tools > Visualization > Camera.

   The Setup Camera tool settings window opens.

2. Following the tool prompt, select a view to be the active view.
   It is recommended that the Isometric view is the active view.

3. Define the camera position in the selected active view so that it is facing the door of the house.

4. Select the Define Camera tool from either the Cameras toolbox or from Tools > Visualization > Camera.

   The Define Camera tool settings window opens.
5. Keep all the default settings, but use the icons to manipulate the camera from the open views, but not from the active view. You can find more information about the different icons in Help > Working with Complete Designs > Visualization > Setting Up the Camera > Cameras Toolbox > Define Camera. When you manipulate the camera in the other views, the active view shows you the results of the changes you made with the camera.

To Create a Rendering of the House

1. Select the Render tool from either the Render toolbox, labeled with a Q, on the Visualization task or from Tools > Visualization > Render.

   The Luxology Render dialog opens.

2. Click the View icon.

   The View drop-down menu opens.
3. Select the view number for the Isometric view.
4. Click the Luxology Render Settings icon drop-down arrow.
5. Select Interior Good.
6. Click the Luxology Environment Settings icon drop-down arrow.
7. Select Physical Sky.
8. Click the Begin Luxology Render icon.
   The Luxology render starts.

When the Luxology render is complete, a realistic rendering of your house design model is created.
Completed designs can be formatted into deliverables that can combine design information with the correct display method. Examples of deliverables you can create in MicroStation are prints of 2D sheet models, 3D PDFs and i-models.

**To Print a 2D Sheet Model**

Printing a sheet model allows you to have a hard copy that contains information from both design and drawing models. Changes in either design or drawing information are reflected in the sheet model and the evolution of a project can be shown through printed documents.

1. In QuickStart.dgn, open the Plan [Sheet] model.
2. Select **File > Print**.
   The Print dialog opens.
3. Optional: In the General Settings section, if you do not have a color printer, change Color to Monochrome or Grayscale.
4. In the Printer and Paper size section, set Paper to the desired size.
   a. Set the Paper orientation to Portrait or Landscape.
5. Select **File > Print** or click the Print icon.
   The sheet model prints.
Creating Deliverables
To Create a 3D PDF

To Create a 3D PDF
A 3D PDF is a universally-accessible design deliverable that contains 3D geometry and relevant business information, in addition to general PDF functionality.

1. In QuickStart.dgn, open the My House model.
2. Select File > Print.

   ![Print dialog](image)

   The Print dialog opens.
3. In the Printer and Paper Size section, select the Bentley driver.
4. Click the magnifying glass 🔍.
5. Select pdf from the list of printer driver configuration files.
6. Turn on the Print to 3D check box.
7. From the Print dialog, click Print.
   Your 3D PDF is created.

   Note: You may want to record the location of the 3D PDF.

To Create an i-model

The i-model combines all the graphics and business data intelligence, as defined by the design application, into a single deliverable container for distribution. Because an i-model optimizes the business data, the result is decreased file size and easier navigation.

1. Open a design model file.
2. Select File > Publish i-model.
   The Publish i-model(s) dialog opens.
3. Click Publish.
   The i-model publishes.
Creating Deliverables
To Create an i-model

![Image of Publish i-model(s) dialog box showing package and publish settings]

- **Package Settings**
  - Create a single package
  - Package: QuickStart
  - Protection: Everyone
  - Rights: View, Export, Print
  - Expires: 2012/08/14
  - Remove intermediate files after creating package

- **Publish Settings**
  - Cache Visible Edges for 3D Attachments
  - Retain Cached Visible Edges Even if Out Of Date
  - Filter Design History
  - Publish Linked Design Files
  - Republish All i-models

[Image of the Publish i-model(s) dialog box]
Key Concepts and Tools

The Key Concepts and Tools resource contains information about important features and tools that were not discussed in the body of the Quick Start Guide. For each topic it gives a short description, the location in MicroStation and how to open it, and where to find information about it in the Help.

AccuSnap

AccuSnap is a snapping mode that may be used by itself, or in combination with AccuDraw, to reduce the number of button presses required during a design session. AccuSnap provides graphical assistance - a smart pointer - for snapping to elements. You can adjust AccuSnap settings to fit your mode of operation.

In MicroStation:

- Snap mode icon in the status bar
- Snap Mode button bar (click the snap mode icon and select Button Bar from the pop-up menu)
- AccuSnap Settings dialog (Settings > Snaps > AccuSnap)

AccuSnap help topics:
• AccuSnap and AccuDraw > Using AccuSnap

Design History

All changes in a model are identified and tied to a specific revision number when design history is on for a file. Changes can be tracked down to the element level. You can restore elements to a prior state through a combination of undoing and redoing historic changes.

In MicroStation:

• Design History toolbox (Tools > Change Tracking > Design History > Open as ToolBox)

Design history help topics:
• Setting Up Projects > Design History

Design Plane and Design Cube

The design plane is the MicroStation equivalent of a sheet of drafting paper. Unlike a sheet of drafting paper, the design plane lets you draw your models at full scale. The design plane is 2D. The design cube is 3D. It contains all the functionality of the design plane with the addition of Z-values.

In MicroStation:

• Located in the view windows. It is where you create your designs.

Design plane and cube help topics:
• Getting Started > Fundamentals > Preparing to Draw > DGN Design Environment
• 3D Design and Modeling > Basic 3D Concepts > Design Cube

DGN Libraries

A DGN library is a file used to store shared resources such as levels, cells, and text styles with the extension .dgnlib instead of .dgn. You can configure MicroStation to use the resources found in DGN libraries.

In MicroStation:

• Dialogs used to create and maintain resources stored in DGN libraries are typically opened from the Element menu.

DGN libraries help topics:
• Setting Up Projects > Building DGN Libraries
Element Attributes

Element attributes are the different characteristics that make up an element and make it unique from other elements. Element attributes include color, line weight, line style, as well as other characteristics.

In MicroStation:

- Attributes toolbox (Menus > Attributes)

Element attributes help topics:
- Creating Drawing Elements > What Are Element Attributes?
- Creating Drawing Elements > Other Element Attributes

Levels

Levels are essential to creating designs in MicroStation. You worked with turning the display of a level on/off in the Quick Start Guide; however, there are many other ways you can use levels. Design, drawing, and sheet models have levels. You can create levels, delete levels, import/export levels, lock/unlock levels, and filter levels along with additional ways to interact with levels. Only one level can be active at a time, but you can have many levels within one model.

In MicroStation:
- Active level control in the Attributes toolbox, which is docked to the top of the application window by default

- Level Manager dialog (click the Level Manager icon in the Primary Tools toolbox)
Level Display dialog (click the Level Display icon in the Primary Tools toolbox)

Level help topics:
- Getting Started > Levels
- Setting Up Projects > The Level System

**Project Explorer and Link Sets**

Project Explorer provides hierarchical storage for information related to design such as DGN and DWG files, models, references, Adobe PDFs, Microsoft Word documents, Microsoft Excel workbooks, and their contents. Link sets are an important component of Project Explorer. They are used to organize project data.

In MicroStation:
-
Project Explorer Settings dialog

- Link Sets dialog (Opens when the Manage Link Sets icon is clicked in the Links tab of the Project Explorer dialog)

Project Explorer and link sets help topics:

- Setting Up Projects > Managing Project Data with Project Explorer and Link Sets

**Seed Files**

Seed files are the foundation that other files are built upon in MicroStation. A seed file contains preset values such as initial element parameters, dimensionality (2D or 3D), working units settings, and initial design elements.

In MicroStation:

![New File dialog (File > New)](image)

New File dialog (File > New), Seed field and adjacent Browse button
A workspace is a custom MicroStation configuration that is set up by an administrator. By selecting a workspace, you customize MicroStation for a specific discipline, project, or task.

MicroStation is delivered with a sample workspace containing example files, which show many MicroStation features. When a workspace is active, the files and tools you need to perform specific design work are available. Tools that are not necessary are removed from the interface.

In MicroStation:

- File Open dialog (File > Open)
Additional Resources

Key Concepts and Tools

- About Workspace window (Workspace > About Workspace)
Additional Resources

Key Concepts and Tools

- Preferences dialog (Workspace > Preferences)
- Configuration dialog (Workspace > Configuration)
- Customize dialog (Workspace > Customize)
Workspaces help topics:

- Setting Up Projects > Workspaces > Workspace Fundamentals
- Setting Up Projects > Workspaces > Workspace Configuration
- Setting Up Projects > Workspaces > Customizing the User Interface
- Getting Started > Fundamentals > User Preferences

**The Bentley Institute**

*The Bentley Institute* is a world class educational institution. It is a global learning community that seeks to educate and sustain current and future generations of infrastructure professionals to best serve the world in the 21st century. The Bentley Institute's library of courses exceeds 1,850 titles and 17,000 hours of learning, and its training materials are produced in more than 12 languages for delivery across 170 countries.

**Be Communities**

*Be Communities* is hosted by Bentley for the world's infrastructure community members to connect, communicate, share, and learn from each other through forums, wikis, blogs, and resource libraries. Be Communities is for anyone involved with infrastructure, including current and potential users of Bentley's solutions, Bentley colleagues, and others.
This page intentionally left blank